vSphere Console black screen / MKS Error

vSphere Console black screen / MKS Error

Symptom

When attempting to launch the VMware vSphere Web Console or VMRC from vCenter, the console launches but cannot connect. This issue also effects the vSphere Web Client. 

Errors may be present like: 
Unable to connect to the MKS: SSL required .
Unable to connect to the MKS: Login failed

Or only a black screen may appear.


Environment

VMware vCenter 6.5
VMware vCenter 6.7 &
Microsoft Windows


Cause

There are SSL errors present in your environment preventing the MKS from making a successful connection.


Resolution

SSL authentication is enabled on ESX/ESXi hosts by default. 
If disabled SSL on a host, you must enable it again before you can use VMware Remote Console (VMRC) to access a virtual machine.

Via SSH or ESXi Shell
  1. Connect directly to the host as a user with root privileges. The ESXi 5.0 host can be accessed using Tech Support Mode (TSM). ESXi 5.1 and later include the ESXi shell.
  2. Open the /etc/vmware/config file using a text editor.
  3. Locate the security.host.ruissl entry.
  4. Change the value of security.host.ruissl from FALSE to TRUE

    If it is set to no, change it to yes .

Note: If the security.host.ruissl entry is not available in the /etc/vmware/config file, add the entry and set it to appropriate value.

It is important to restart the hostd and vpxa service after making this configuration change.

The commands are as follows:
      /etc/init.d/hostd stop
      /etc/init.d/hostd start
      /etc/init.d/vpxa stop
      /etc/initd/vpxa start


References


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